What needs to be done to make the MVP400 with 3.01x firmware work with the MVP2400?

You will need to run H.323 firmware on the MVP400 for this to work with the MVP2400.
Go to: http://www.multitech.com/en_US/SUPPORT/Families/MultiVOIP/firmware and download 3.52 or newer. Extract the file in a clean directory, and refer to the readme.txt to view instructions for upgrading the mvp400 firmware from proprietary to H323.