I am having a problem linking two MVP200s, one is running Proprietary firmware while the other is H.323 (H323).

The MultiVOIPs need to be running the same protocol in order to connect to each other. What you should do is select the protocol you wish to run and then load that into the unit that needs it with the "upgrade software" option. 2.01h is the latest proprietary version and 2.52 is the latest H.323 version. MVP110 and MVP120 current proprietary firmware is 7.01h and h.323 is 7.52a.

These can be downloaded from our website at:

http://www.multitech.com/en_US/SUPPORT/Families/MultiVOIP/firmware