How do I determine the MTAC-LORA-H card's FPGA firmware version?

You can check the FPGA version using the following command:
mts-fpga-loader -c 

It will require mlinux v3.3.12 or higher or AEP 1.4.11 or higher.

Currently there is no programmatical way to determine the revision of the board.