Do you have Windows 2003 drivers for your ISI modems? Does your card and or drivers require SP1 for proper operation?

Yes, you can use the same windows 2000 driver for Windows 2003 OS for the ISI cards. No, our card does not require SP1.


The latest ISI drivers can be downloaded from our Web site at:

http://www.multitech.com/en_US/SUPPORT/Families/MultiModemISI/drivers